{"id":"CVE-2026-53615","url":"https://www.cyber-defence.io/tools/cve/CVE-2026-53615","generatedAt":"2026-10-28T09:27:15.928Z","title":"A local attacker who causes a crafted DOS extended-partition disk image or removable medium to be probed can wrap `cur_start + start` to sector zero and cause libblkid to report a false partition overlapping the MBR.","description":"util-linux is a random collection of Linux utilities. Before util-linux 2.41.4, `parse_dos_extended()` in `libblkid/src/partitions/dos.c` computes an extended-partition start sector with 32-bit addition and does not apply the extended-area bounds checks to the first two EBR entries. A local attacker who causes a crafted DOS extended-partition disk image or removable medium to be probed can wrap `cur_start + start` to sector zero and cause libblkid to report a false partition overlapping the MBR. This directly compromises the integrity of the reported partition metadata; disk modification or availability loss requires a separate downstream consumer to act on that metadata. This issue is fixed in 2.41.4.","published":"2026-10-14T16:17:46.000Z","lastModified":"2026-10-16T16:00:34.000Z","status":"Awaiting Analysis","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"3.1","score":8,"severity":"HIGH","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H"},"cwe":["CWE-190"],"affected":[],"epss":{"score":0.00178,"percentile":0.07264,"date":"2026-10-27","history":[{"date":"2026-10-15","score":0.00178,"percentile":0.06823}]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"high","text":"High impact if exploited, but EPSS currently rates exploitation as unlikely (0.18%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit."},"changes":[{"kind":"new","label":"New CVE","at":"2026-10-14T16:17:46.000Z","detail":{"score":"8.0","severity":"HIGH","publishedAt":"2026-10-14T16:17:46.070Z"},"summary":"New CVE, high severity (CVSS 8.0)."}],"references":[{"url":"https://github.com/util-linux/util-linux/commit/05c2dbadf34cc74192287f377904afaaf4061623","source":"security-advisories@github.com"},{"url":"https://github.com/util-linux/util-linux/commit/a2d858176b609ab5b8535021a3af9cd302d23d31","source":"security-advisories@github.com"},{"url":"https://github.com/util-linux/util-linux/commit/e9d544d013267ea86b70ee8ff78abd280e6641af","source":"security-advisories@github.com"},{"url":"https://github.com/util-linux/util-linux/releases/tag/v2.41.4","source":"security-advisories@github.com"},{"url":"https://github.com/util-linux/util-linux/security/advisories/GHSA-h4rw-gv36-wmp5","source":"security-advisories@github.com"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2026-53615","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}