{"id":"CVE-2026-53614","url":"https://www.cyber-defence.io/tools/cve/CVE-2026-53614","generatedAt":"2026-10-28T09:27:30.757Z","title":"In util-linux 2.39.1 through 2.41.4 and 2.42 through 2.42.1, the SUID `mount` utility reads the attacker-controlled `LIBMOUNT_FORCE_MOUNT2` environment variable with `getenv()`, allowing a local low-privileged user to force the non-atomic legacy…","description":"util-linux is a random collection of Linux utilities. In util-linux 2.39.1 through 2.41.4 and 2.42 through 2.42.1, the SUID `mount` utility reads the attacker-controlled `LIBMOUNT_FORCE_MOUNT2` environment variable with `getenv()`, allowing a local low-privileged\nuser to force the non-atomic legacy bind-mount path. With an `/etc/fstab` bind mount authorized by `user` or `users` and protected by `nosuid`, `noexec`, or `nodev`, an attacker can race the window between the initial bind mount and the remount that applies those security flags and execute a SUID program from the temporarily unprotected mount, potentially gaining root privileges. This issue is fixed in 2.41.5 and 2.42.2.","published":"2026-10-14T16:17:46.000Z","lastModified":"2026-10-16T16:00:34.000Z","status":"Awaiting Analysis","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"3.1","score":7,"severity":"HIGH","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H"},"cwe":["CWE-269","CWE-807"],"affected":[],"epss":{"score":0.00133,"percentile":0.02814,"date":"2026-10-27","history":[{"date":"2026-10-15","score":0.00139,"percentile":0.02903}]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"high","text":"High impact if exploited, but EPSS currently rates exploitation as unlikely (0.13%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit."},"changes":[{"kind":"new","label":"New CVE","at":"2026-10-14T16:17:46.000Z","detail":{"score":"7.0","severity":"HIGH","publishedAt":"2026-10-14T16:17:45.930Z"},"summary":"New CVE, high severity (CVSS 7.0)."}],"references":[{"url":"https://github.com/util-linux/util-linux/commit/31e37c1c7dcf25b76ccf41391fe934a75644c661","source":"security-advisories@github.com"},{"url":"https://github.com/util-linux/util-linux/commit/53ff0fcdab12d69c60c971c69a3d0d173fa46ca9","source":"security-advisories@github.com"},{"url":"https://github.com/util-linux/util-linux/commit/9cbfb823500f510b34767edabd3ffd5b436987b4","source":"security-advisories@github.com"},{"url":"https://github.com/util-linux/util-linux/commit/cc81bbcec598cb91f0eb8456282f33eed820ed5f","source":"security-advisories@github.com"},{"url":"https://github.com/util-linux/util-linux/commit/fd6b4d94ff013dc7ed680d4e864610da5b9751f1","source":"security-advisories@github.com"},{"url":"https://github.com/util-linux/util-linux/releases/tag/v2.41.5","source":"security-advisories@github.com"},{"url":"https://github.com/util-linux/util-linux/releases/tag/v2.42.2","source":"security-advisories@github.com"},{"url":"https://github.com/util-linux/util-linux/security/advisories/GHSA-67r7-8m5w-22wx","source":"security-advisories@github.com"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2026-53614","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}