{"id":"CVE-2026-47137","url":"https://www.cyber-defence.io/tools/cve/CVE-2026-47137","generatedAt":"2026-10-28T03:41:18.454Z","title":"However, the check uses strict equality (options.require === false), which is trivially bypassed by omitting the require option entirely.","description":"vm2 is an open source vm/sandbox for Node.js. Prior to version 3.11.4, the fix for GHSA-8hg8-63c5-gwmx (CVE-2023-37903) introduced a check in nodevm.js line 263 that blocks the combination nesting: true + require: false. However, the check uses strict equality (options.require === false), which is trivially bypassed by omitting the require option entirely. When require is not specified, options.require is undefined, not false. The strict equality check fails, so the security guard is skipped. Immediately after (line 280), the destructuring default require: requireOpts = false assigns requireOpts = false, producing the exact configuration the patch was designed to prevent. This issue has been patched in version 3.11.4.","published":"2026-06-12T15:16:28.000Z","lastModified":"2026-10-26T11:10:00.000Z","status":"Deferred","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"3.1","score":10,"severity":"CRITICAL","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H"},"cwe":["CWE-913"],"affected":[],"epss":{"score":0.00382,"percentile":0.31994,"date":"2026-10-27","history":[]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"high","text":"High impact if exploited, but EPSS currently rates exploitation as unlikely (0.38%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit."},"changes":[],"references":[{"url":"https://github.com/advisories/GHSA-g644-9gfx-q4q4","source":"security-advisories@github.com"},{"url":"https://github.com/patriksimek/vm2/commit/01a7552add345d5a6862623884e6b79a85bf0568","source":"security-advisories@github.com"},{"url":"https://github.com/patriksimek/vm2/commit/86ab819f202c3a8dad88cef5705f2e416c5188d7","source":"security-advisories@github.com"},{"url":"https://github.com/patriksimek/vm2/releases/tag/v3.11.4","source":"security-advisories@github.com"},{"url":"https://github.com/patriksimek/vm2/security/advisories/GHSA-m4wx-m65x-ghrr","source":"security-advisories@github.com"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2026-47137","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}