{"id":"CVE-2026-41677","url":"https://www.cyber-defence.io/tools/cve/CVE-2026-41677","generatedAt":"2026-10-28T02:20:17.214Z","title":"This vulnerability is fixed in 0.10.78.","description":"rust-openssl provides OpenSSL bindings for the Rust programming language.  From 0.9.0 to before 0.10.78, the *_from_pem_callback APIs did not validate the length returned by the user's callback. A password callback that returns a value larger than the buffer it was given can cause some versions of OpenSSL to over-read this buffer. OpenSSL 3.x is not affected by this. This vulnerability is fixed in 0.10.78.","published":"2026-04-24T18:16:29.000Z","lastModified":"2026-06-17T10:46:59.000Z","status":"Analyzed","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"4.0","score":1.7,"severity":"LOW","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/M"},"cwe":["CWE-125","CWE-1284"],"affected":["rust-openssl project/rust-openssl"],"epss":{"score":0.00294,"percentile":0.21803,"date":"2026-10-26","history":[]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"low","text":"Lower severity and a low EPSS score (0.29%). Track it; it rarely justifies an emergency change on its own."},"changes":[],"references":[{"url":"https://github.com/rust-openssl/rust-openssl/security/advisories/GHSA-xmgf-hq76-4vx2","tags":["Vendor Advisory"],"source":"security-advisories@github.com"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2026-41677","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}