{"id":"CVE-2026-35479","url":"https://www.cyber-defence.io/tools/cve/CVE-2026-35479","generatedAt":"2026-10-28T00:14:40.833Z","title":"The vulnerability allows staff users (who may be considered to have a lower level of trust than a superuser account) to install arbitrary (and potentially harmful) plugins.","description":"InvenTree is an Open Source Inventory Management System. Prior to 1.2.7 and 1.3.0, any users who have staff access permissions can install plugins via the API, without requiring \"superuser\" account access. This level of permission requirement is out of alignment with other plugin actions (such as uninstalling) which do require superuser access. The vulnerability allows staff users (who may be considered to have a lower level of trust than a superuser account) to install arbitrary (and potentially harmful) plugins. This vulnerability is fixed in 1.2.7 and 1.3.0.","published":"2026-04-08T20:16:25.000Z","lastModified":"2026-10-06T22:10:00.000Z","status":"Analyzed","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"3.1","score":4.7,"severity":"MEDIUM","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L"},"cwe":["CWE-285"],"affected":["inventree project/inventree"],"epss":{"score":0.00216,"percentile":0.11929,"date":"2026-10-26","history":[]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"low","text":"Lower severity and a low EPSS score (0.22%). Track it; it rarely justifies an emergency change on its own."},"changes":[],"references":[{"url":"https://docs.inventree.org/en/stable/concepts/threat_model/#assumed-trust","tags":["Product"],"source":"security-advisories@github.com"},{"url":"https://docs.inventree.org/en/stable/start/config/#plugin-options","tags":["Product"],"source":"security-advisories@github.com"},{"url":"https://github.com/inventree/InvenTree/security/advisories/GHSA-7c3q-vwcv-2vp7","tags":["Third Party Advisory"],"source":"security-advisories@github.com"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2026-35479","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}