{"id":"CVE-2026-115930","url":"https://www.cyber-defence.io/tools/cve/CVE-2026-115930","generatedAt":"2026-10-27T22:47:45.597Z","title":"The MongoDB Shell (mongosh) relies on Node.js as a third-party runtime that carries its own TLS root certificate store.","description":"The MongoDB Shell (mongosh) relies on Node.js as a third-party runtime that carries its own TLS root certificate store. This certificate store has the recoverable eMudhra intermediate CA certificates. This issue impacts MongoDB Shell (mongosh) versions prior to 2.14.0 and can be resolved by updating to mongosh 2.14.0 which bundles Node.js 24.22.1 or later. If mongosh is installed through npm, it uses the Node.js runtime installed on the host; update that runtime separately.","published":"2026-10-26T15:16:39.000Z","lastModified":"2026-10-26T16:54:09.000Z","status":"Awaiting Analysis","sourceIdentifier":"cna@mongodb.com","cvss":{"version":"4.0","score":7.6,"severity":"HIGH","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/M"},"cwe":["CWE-295"],"affected":[],"epss":null,"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"high","text":"High impact if exploited, but EPSS currently rates exploitation as unscored. Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit."},"changes":[{"kind":"new","label":"New CVE","at":"2026-10-26T15:16:39.000Z","detail":{"score":"7.6","severity":"HIGH","publishedAt":"2026-10-26T15:16:39.480Z"},"summary":"New CVE, high severity (CVSS 7.6)."}],"references":[{"url":"https://www.mongodb.com/docs/mongodb-shell/changelog/","source":"cna@mongodb.com"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2026-115930","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}