{"id":"CVE-2026-112362","url":"https://www.cyber-defence.io/tools/cve/CVE-2026-112362","generatedAt":"2026-10-28T01:51:26.300Z","title":"An unauthenticated attacker needs only the non-default ignoreDuplicateSlashes option to be enabled.","description":"@fastify/express is a Fastify plugin that runs Express middleware inside Fastify. In versions 4.0.5 through 4.0.8, when Fastify runs with the non-default ignoreDuplicateSlashes option enabled, the plugin matches path-scoped Express middleware against a URL whose duplicate-slash normalization has also collapsed the separator after an absolute-form request target's scheme, so Fastify's router resolves the request to the scoped path and runs the handler while the Express layer no longer sees that path. As a result, a request using an absolute-form target can reach a handler on a scoped route such as an admin path while the middleware for authentication, authorization, or rate limiting is skipped. An unauthenticated attacker needs only the non-default ignoreDuplicateSlashes option to be enabled. The issue is fixed in @fastify/express 4.0.9, and users should upgrade to 4.0.9 or later. As a workaround, enforce authentication in a Fastify hook such as preHandler that runs after the router resolves the request, or leave ignoreDuplicateSlashes at its default.","published":"2026-10-27T12:17:05.000Z","lastModified":"2026-10-27T15:03:41.000Z","status":"Awaiting Analysis","sourceIdentifier":"ce714d77-add3-4f53-aff5-83d477b104bb","cvss":{"version":"3.1","score":9.1,"severity":"CRITICAL","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N"},"cwe":["CWE-436"],"affected":[],"epss":null,"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"high","text":"High impact if exploited, but EPSS currently rates exploitation as unscored. Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit."},"changes":[{"kind":"new","label":"New CVE","at":"2026-10-27T12:17:05.000Z","detail":{"score":"9.1","severity":"CRITICAL","publishedAt":"2026-10-27T12:17:04.970Z"},"summary":"New CVE, critical severity (CVSS 9.1)."}],"references":[{"url":"https://cna.openjsf.org/security-advisories.html","source":"ce714d77-add3-4f53-aff5-83d477b104bb"},{"url":"https://github.com/fastify/fastify-express/security/advisories/GHSA-6h42-57hq-9746","source":"ce714d77-add3-4f53-aff5-83d477b104bb"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2026-112362","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}