{"id":"CVE-2026-111235","url":"https://www.cyber-defence.io/tools/cve/CVE-2026-111235","generatedAt":"2026-10-28T01:11:48.169Z","title":"An authorization bypass vulnerability exists in the REST API of multiple versions of OpenNMS Meridian and Horizon.","description":"An authorization bypass vulnerability exists in the REST API of multiple versions of OpenNMS Meridian and Horizon. The /rest/** Spring Security filter chains authorize requests with intercept-url rules that name the HTTP method as an uppercase token, compare the method case-sensitively, and have no terminal deny rule. A request that uses a non-canonical (for example lowercase) method token matches no rule and is processed without authentication. A remote, unauthenticated attacker can read the monitored inventory and can create, modify, or delete resources through the REST API, which includes injecting events to fabricate or suppress alarms. The /rest/alarms chain has the same missing deny rule and discloses whether an alarm exists through a difference in the response. The fix adds a terminal deny rule to each REST filter chain.\n\n\n\nThe solution is to upgrade to Meridian 2024.3.14, 2025.0.11, 2026.0.1 and Horizon 36.0.5 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.","published":"2026-10-15T19:17:37.000Z","lastModified":"2026-10-16T20:17:20.000Z","status":"Awaiting Analysis","sourceIdentifier":"security@opennms.com","cvss":{"version":"3.1","score":9.1,"severity":"CRITICAL","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N"},"cwe":["CWE-204","CWE-862","CWE-863"],"affected":[],"epss":{"score":0.00376,"percentile":0.31368,"date":"2026-10-26","history":[{"date":"2026-10-16","score":0.00376,"percentile":0.30035}]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"high","text":"High impact if exploited, but EPSS currently rates exploitation as unlikely (0.38%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit."},"changes":[{"kind":"new","label":"New CVE","at":"2026-10-15T19:17:37.000Z","detail":{"score":"9.1","severity":"CRITICAL","publishedAt":"2026-10-15T19:17:36.693Z"},"summary":"New CVE, critical severity (CVSS 9.1)."}],"references":[{"url":"https://github.com/OpenNMS/opennms/pull/8934","source":"security@opennms.com"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2026-111235","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}