{"id":"CVE-2026-107318","url":"https://www.cyber-defence.io/tools/cve/CVE-2026-107318","generatedAt":"2026-10-28T04:18:26.994Z","title":"In versions prior to 12.7.0, all of the built-in HTTPS transports override the secure default and set rejectUnauthorized to false, so the proxy does not verify the TLS certificate of the upstream even when the application points it at an https upstream…","description":"@fastify/reply-from is a Fastify plugin that forwards requests to an upstream HTTP or HTTPS server. In versions prior to 12.7.0, all of the built-in HTTPS transports override the secure default and set rejectUnauthorized to false, so the proxy does not verify the TLS certificate of the upstream even when the application points it at an https upstream in the default configuration. An on-path network attacker can therefore impersonate the configured HTTPS upstream, read the credentials and request bodies the proxy forwards, and return forged responses that the application trusts. The issue is fixed in @fastify/reply-from 12.7.0, and users should upgrade to 12.7.0 or later. As a workaround, pass an explicit rejectUnauthorized true on the transport, supply an already configured undici instance, or use the undici global agent.","published":"2026-10-08T21:17:52.000Z","lastModified":"2026-10-09T12:17:08.000Z","status":"Deferred","sourceIdentifier":"ce714d77-add3-4f53-aff5-83d477b104bb","cvss":{"version":"3.1","score":7.4,"severity":"HIGH","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N"},"cwe":["CWE-295"],"affected":[],"epss":{"score":0.00145,"percentile":0.03754,"date":"2026-10-27","history":[{"date":"2026-10-09","score":0.00145,"percentile":0.03305}]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"high","text":"High impact if exploited, but EPSS currently rates exploitation as unlikely (0.14%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit."},"changes":[{"kind":"new","label":"New CVE","at":"2026-10-08T21:17:52.000Z","detail":{"score":"7.4","severity":"HIGH","publishedAt":"2026-10-08T21:17:51.807Z"},"summary":"New CVE, high severity (CVSS 7.4)."}],"references":[{"url":"https://cna.openjsf.org/security-advisories.html","source":"ce714d77-add3-4f53-aff5-83d477b104bb"},{"url":"https://github.com/fastify/fastify-reply-from/security/advisories/GHSA-j425-jw94-m29r","source":"ce714d77-add3-4f53-aff5-83d477b104bb"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2026-107318","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}