{"id":"CVE-2025-68614","url":"https://www.cyber-defence.io/tools/cve/CVE-2025-68614","generatedAt":"2026-10-27T23:08:10.845Z","title":"Prior to version 25.12.0, the Alert Rule API is vulnerable to stored cross-site scripting.","description":"LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.12.0, the Alert Rule API is vulnerable to stored cross-site scripting. Alert rules can be created or updated via LibreNMS API. The alert rule name is not properly sanitized, and can be used to inject HTML code. This issue has been patched in version 25.12.0.","published":"2025-12-23T00:15:44.000Z","lastModified":"2026-10-19T22:10:00.000Z","status":"Analyzed","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"3.1","score":5.4,"severity":"MEDIUM","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"},"cwe":["CWE-79"],"affected":["librenms/librenms"],"epss":{"score":0.03884,"percentile":0.90154,"date":"2026-10-26","history":[]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"low","text":"Lower severity and a low EPSS score (3.88%). Track it; it rarely justifies an emergency change on its own."},"changes":[],"references":[{"url":"https://github.com/librenms/librenms/commit/ebe6c79bf4ce0afeb575c1285afe3934e44001f1","tags":["Patch"],"source":"security-advisories@github.com"},{"url":"https://github.com/librenms/librenms/security/advisories/GHSA-c89f-8g7g-59wj","tags":["Exploit","Vendor Advisory"],"source":"security-advisories@github.com"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2025-68614","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}