{"id":"CVE-2025-61594","url":"https://www.cyber-defence.io/tools/cve/CVE-2025-61594","generatedAt":"2026-10-28T03:24:41.494Z","title":"In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the…","description":"URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.","published":"2025-12-30T21:15:44.000Z","lastModified":"2026-06-17T09:50:37.000Z","status":"Modified","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"4.0","score":2.1,"severity":"LOW","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/M"},"cwe":["CWE-200","CWE-212"],"affected":["ruby-lang/uri"],"epss":{"score":0.0056,"percentile":0.46324,"date":"2026-10-26","history":[]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"low","text":"Lower severity and a low EPSS score (0.56%). Track it; it rarely justifies an emergency change on its own."},"changes":[],"references":[{"url":"https://github.com/advisories/GHSA-22h5-pq3x-2gf2","source":"security-advisories@github.com"},{"url":"https://github.com/ruby/uri/security/advisories/GHSA-j4pr-3wm6-xx2r","source":"security-advisories@github.com"},{"url":"https://hackerone.com/reports/2957667","source":"security-advisories@github.com"},{"url":"https://www.ruby-lang.org/en/news/2025/02/26/security-advisories","source":"security-advisories@github.com"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2025-61594","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}