{"id":"CVE-2025-58360","url":"https://www.cyber-defence.io/tools/cve/CVE-2025-58360","generatedAt":"2026-10-31T05:59:15.157Z","title":"OSGeo GeoServer Improper Restriction of XML External Entity Reference Vulnerability","description":"GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.","published":"2025-11-25T21:15:56.000Z","lastModified":"2026-10-18T20:10:00.000Z","status":"Analyzed","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"3.1","score":9.8,"severity":"CRITICAL","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"},"cwe":["CWE-611"],"affected":["geoserver/geoserver"],"epss":{"score":0.61169,"percentile":0.9916,"date":"2026-10-30","history":[{"date":"2026-09-24","score":0.60522,"percentile":0.99117},{"date":"2026-10-26","score":0.61169,"percentile":0.99155}]},"kev":{"listed":true,"dateAdded":"2025-12-11","dueDate":"2026-01-01","knownRansomwareCampaignUse":"Unknown","notes":"Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.\nThis vulnerability affects an open-source component, third-party library, or a protocol used by different products. For more information, please see: https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525 ; https://osgeo-org.atlassian.net/browse/GEOS-11922 ; https://nvd.nist.gov/vuln/detail/CVE-2025-58360"},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"urgent","text":"Known to be exploited in the wild (CISA KEV, CISA remediation deadline 1 January 2026). Treat as an emergency change: patch or isolate now, then hunt for prior compromise."},"changes":[],"references":[{"url":"https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525","tags":["Vendor Advisory"],"source":"security-advisories@github.com"},{"url":"https://osgeo-org.atlassian.net/browse/GEOS-11682","tags":["Issue Tracking"],"source":"security-advisories@github.com"},{"url":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-58360","tags":["US Government Resource"],"source":"134c704f-9b21-4f2e-91b3-4a467353bcc0"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2025-58360","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}