{"id":"CVE-2025-46818","url":"https://www.cyber-defence.io/tools/cve/CVE-2025-46818","generatedAt":"2026-10-28T03:30:58.322Z","title":"Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to manipulate different LUA objects and potentially run their own code in the context of another user.","description":"Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to manipulate different LUA objects and potentially run their own code in the context of another user. The problem exists in all versions of Redis with LUA scripting. This issue is fixed in version 8.2.2. A workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing LUA scripts. This can be done using ACL to block a script by restricting both the EVAL and FUNCTION command families.","published":"2025-10-03T19:15:43.000Z","lastModified":"2026-10-19T17:10:00.000Z","status":"Analyzed","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"3.1","score":7.3,"severity":"HIGH","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H"},"cwe":["CWE-94"],"affected":["redis/redis"],"epss":{"score":0.00744,"percentile":0.54466,"date":"2026-10-26","history":[]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"high","text":"High impact if exploited, but EPSS currently rates exploitation as unlikely (0.74%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit."},"changes":[],"references":[{"url":"https://github.com/redis/redis/commit/45eac0262028c771b6f5307372814b75f49f7a9e","tags":["Patch"],"source":"security-advisories@github.com"},{"url":"https://github.com/redis/redis/releases/tag/8.2.2","tags":["Release Notes"],"source":"security-advisories@github.com"},{"url":"https://github.com/redis/redis/security/advisories/GHSA-qrv7-wcrx-q5jp","tags":["Third Party Advisory"],"source":"security-advisories@github.com"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2025-46818","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}