{"id":"CVE-2025-46731","url":"https://www.cyber-defence.io/tools/cve/CVE-2025-46731","generatedAt":"2026-10-28T07:26:06.772Z","title":"Versions of Craft CMS on the 4.x branch prior to 4.14.13 and on the 5.x branch prior to 5.6.16 contains a potential remote code execution vulnerability via Twig SSTI.","description":"Craft is a content management system. Versions of Craft CMS on the 4.x branch prior to 4.14.13 and on the 5.x branch prior to 5.6.16 contains a potential remote code execution vulnerability via Twig SSTI. One must have administrator access and `ALLOW_ADMIN_CHANGES` must be enabled for this to work. Users should update to the patched versions 4.14.13 or 5.6.15 to mitigate the issue.","published":"2025-05-05T20:15:21.000Z","lastModified":"2026-06-17T09:26:54.000Z","status":"Analyzed","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"4.0","score":7.3,"severity":"HIGH","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/M"},"cwe":["CWE-1336"],"affected":["craftcms/craft cms"],"epss":{"score":0.01518,"percentile":0.74417,"date":"2026-10-27","history":[]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"high","text":"High impact if exploited, but EPSS currently rates exploitation as unlikely (1.52%). Schedule it in the normal patch cycle and watch for a rise in EPSS or a public exploit."},"changes":[],"references":[{"url":"http://github.com/craftcms/cms/pull/17026","tags":["Patch"],"source":"security-advisories@github.com"},{"url":"https://craftcms.com/knowledge-base/securing-craft#set-allowAdminChanges-to-false-in-production","tags":["Product"],"source":"security-advisories@github.com"},{"url":"https://github.com/craftcms/cms/security/advisories/GHSA-7c58-g782-9j38","tags":["Third Party Advisory"],"source":"security-advisories@github.com"},{"url":"https://github.com/craftcms/cms/security/advisories/GHSA-f3cw-hg6r-chfv","tags":["Not Applicable"],"source":"security-advisories@github.com"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2025-46731","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}