{"id":"CVE-2025-24854","url":"https://www.cyber-defence.io/tools/cve/CVE-2025-24854","generatedAt":"2026-10-28T02:24:02.317Z","title":"A carefully crafted request using the Image plugin could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim.","description":"A carefully crafted request using the Image plugin could trigger an XSS \nvulnerability on Apache JSPWiki, which could allow the attacker to \nexecute javascript in the victim's browser and get some sensitive \ninformation about the victim.\n\n\n\n\n\nApache JSPWiki users should upgrade to 2.12.3 or later.","published":"2025-07-31T09:15:28.000Z","lastModified":"2026-06-17T08:59:44.000Z","status":"Modified","sourceIdentifier":"security@apache.org","cvss":{"version":"3.1","score":6.1,"severity":"MEDIUM","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"},"cwe":["CWE-79"],"affected":["apache/jspwiki"],"epss":{"score":0.00475,"percentile":0.40764,"date":"2026-10-26","history":[]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"low","text":"Lower severity and a low EPSS score (0.47%). Track it; it rarely justifies an emergency change on its own."},"changes":[],"references":[{"url":"https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2025-24854","tags":["Vendor Advisory"],"source":"security@apache.org"},{"url":"http://www.openwall.com/lists/oss-security/2025/07/30/3","source":"af854a3a-2127-422b-91ae-364da2661108"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2025-24854","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}