{"id":"CVE-2024-56321","url":"https://www.cyber-defence.io/tools/cve/CVE-2024-56321","generatedAt":"2026-10-28T04:03:35.600Z","title":"GoCD versions 18.9.0 through 24.4.0 (inclusive) can allow GoCD admins to abuse the backup configuration \"post-backup script\" feature to potentially execute arbitrary scripts on the hosting server or container as GoCD's user, rather than pre-configured…","description":"GoCD is a continuous deliver server. GoCD versions 18.9.0 through 24.4.0 (inclusive) can allow GoCD admins to abuse the backup configuration \"post-backup script\" feature to potentially execute arbitrary scripts on the hosting server or container as GoCD's user, rather than pre-configured scripts. In practice the impact of this vulnerability is limited, as in most configurations a user who can log into the GoCD UI as an admin also has host administration permissions for the host/container that GoCD runs on, in order to manage artifact storage and other service-level configuration options. Additionally, since a GoCD admin has ability to configure and schedule pipelines tasks on all GoCD agents available to the server, the fundamental functionality of GoCD allows co-ordinated task execution similar to that of post-backup-scripts. However in restricted environments where the host administration is separated from the role of a GoCD admin, this may be unexpected. The issue is fixed in GoCD 24.5.0. Post-backup scripts can no longer be executed from within certain sensitive locations on the GoCD server. No known workarounds are available.","published":"2025-01-03T16:15:26.000Z","lastModified":"2026-06-17T08:12:02.000Z","status":"Analyzed","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"3.1","score":3.8,"severity":"LOW","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N"},"cwe":["CWE-20","CWE-36"],"affected":["thoughtworks/gocd"],"epss":{"score":0.00561,"percentile":0.46507,"date":"2026-10-27","history":[]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"low","text":"Lower severity and a low EPSS score (0.56%). Track it; it rarely justifies an emergency change on its own."},"changes":[],"references":[{"url":"https://github.com/gocd/gocd/commit/631f315d17fcb73f310eee6c881974c9b55ca9f0","tags":["Patch"],"source":"security-advisories@github.com"},{"url":"https://github.com/gocd/gocd/releases/tag/24.5.0","tags":["Release Notes"],"source":"security-advisories@github.com"},{"url":"https://github.com/gocd/gocd/security/advisories/GHSA-7jr3-gh3w-vjxq","tags":["Vendor Advisory"],"source":"security-advisories@github.com"},{"url":"https://www.gocd.org/releases/#24-5-0","tags":["Release Notes"],"source":"security-advisories@github.com"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2024-56321","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}