{"id":"CVE-2024-43792","url":"https://www.cyber-defence.io/tools/cve/CVE-2024-43792","generatedAt":"2026-10-28T03:26:16.833Z","title":"A security vulnerability has been identified in versions prior to 2.17.0 of the Halo project.","description":"Halo is an open source website building tool. A security vulnerability has been identified in versions prior to 2.17.0 of the Halo project. This vulnerability allows an attacker to execute malicious scripts in the user's browser through specific HTML and JavaScript code, potentially leading to a Cross-Site Scripting (XSS) attack. Users are advised to upgrade to version 2.17.0+. There are no known workarounds for this vulnerability.","published":"2024-09-02T18:15:36.000Z","lastModified":"2026-06-17T07:51:43.000Z","status":"Analyzed","sourceIdentifier":"security-advisories@github.com","cvss":{"version":"3.1","score":6.1,"severity":"MEDIUM","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"},"cwe":["CWE-79"],"affected":["halo/halo"],"epss":{"score":0.00351,"percentile":0.28487,"date":"2026-10-26","history":[]},"kev":{"listed":false},"exploits":{"count":0,"verified":false,"firstPublished":null,"source":"Exploit-DB (https://gitlab.com/exploit-database/exploitdb)","entries":[]},"verdict":{"level":"low","text":"Lower severity and a low EPSS score (0.35%). Track it; it rarely justifies an emergency change on its own."},"changes":[],"references":[{"url":"https://github.com/halo-dev/halo/security/advisories/GHSA-x3rj-3x75-vw4g","tags":["Exploit","Vendor Advisory"],"source":"security-advisories@github.com"}],"sources":{"nvd":"https://nvd.nist.gov/vuln/detail/CVE-2024-43792","epss":"https://www.first.org/epss/","kev":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog","exploitdb":"https://www.exploit-db.com/"},"licence":"CC BY 4.0 — link back to the CVE Explorer if you publish the results; upstream data remains subject to its own terms."}